Emails from safe sender list domain going to Junk

Hi Readers,

 I want to Share my current experience as this issue was esacalated at higher level.(some application that will generate email needs to go live)

We have implemented Safe Sender list via GPO & from outlook we can see that its getting in there.

But it is not working as expected, emails from the domain in safe sender list was still going to Junk folder.

We have logged a case with MS but with no success as they were suspecting the email junk rule corruption & want us to use mfcmapi to remove

Junk email rule message from the mailbox as they have seen this with other customer but our case turned out to be different.

I have started troubleshooting , found that OWA list & Outlook safe sender list are not in sync for many users.

Then I have coordinated with our AD team to check the GPO if evrything is perfect & the answer was yes, eventually I have opened the safesender list  & found that there are spaces at the tail, so I have asked the AD team to remove those.

After doing the above issue got resolved.

 

Thanks

Vikas

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s