Sharepoint Server is showing Installation Required

Hi Readers,

Want to share  important troubleshooting related to Sharepoint 2010 , Suddenly one of our SP server started showing Installation Required.

Nothing has been changed or updated on SharePoint. Tried running the configuration wizard again on the farm but it did’nt helped.

Searched internet but it seems people that got this problem ran the config wizard by using below command, but in our case that didn’t helped.

psconfig.exe -cmd upgrade -inplace b2b -force -cmd installcheck -noinstallcheck

According to Microsoft this can happen if temp files are deleted or installer folder is cleaned-up on the server.

They have provided us two utilities:

1. ROIScan  (To check what is missing from installer)

2. Oputil (To restore the missing elements from the working server)

We ran Oputil as below:

Run “Oputil.vbs /srestorelocation=\\workingserver\c$\windows\installer”

After running this , Next day our server started reporting as upgrade in progress.

Capture

We ran Config wizard & now its showing No Action Required 🙂

Download the Roiscan/oputil from below location:

http://1drv.ms/1FCfIsk

Regards

Sukhija Vikas

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s